am77.de

Grafik Design, Interaktive Gestaltung, Spiele, Motion Graphics

Archive for the ‘flashdevelop’ tag

OpenFl haxe Flashdevelop troubleshooting

leave a comment

Debugging OpenFL in Flashdevelop:

http://stackoverflow.com/a/27660185/4021977

Written by am

January 28th, 2015 at 7:54 pm

Posted in haxe,OpenFL,programming

Tagged with

Flashdevelop jvm.dll Fehler

leave a comment

Hatte diese Fehlermeldung in Flashdevelop:

---
Build succeeded
Done(0)
Debugger startup error: System.TypeInitializationException: The type initializer for 'net.sf.jni4net.jni.JNI' threw an exception. ---> System.DllNotFoundException: Unable to load DLL 'jvm.dll': The specified module could not be found. (Exception from HRESULT: 0x8007007E)
at net.sf.jni4net.jni.JNI.Dll.JNI_GetDefaultJavaVMInitArgs(JavaVMInitArgs* args)
at net.sf.jni4net.jni.JNI.Init()
at net.sf.jni4net.jni.JNI..cctor()
--- End of inner exception stack trace ---
at net.sf.jni4net.jni.JNI.CreateJavaVM(JavaVM& jvm, JNIEnv& env, Boolean attachIfExists, String[] options)
at net.sf.jni4net.Bridge.CreateJVM()
at net.sf.jni4net.Bridge.CreateJVM(BridgeSetup setup)
at FlashDebugger.DebuggerManager.Start()
[Capturing traces with FDB]
---

– bei mir half (nehme ich an), die ‘msvcr71.dll’ (aus z.b. ‘Java\jre6\bin’) in C:\Windows\SysWOW64 zu kopieren, man kann auch C:\Windows\System32 probieren. Auf Win7 64bit macht aber wohl SysWOW64 mehr Sinn
– FÜr Flashdevelop sollte man immer die 32bit-Version von Java 1.6 verwenden, weil die Flex SDK wohl nur mit dieser kompatibel ist (Java SE Runtime Environment 6u45 von http://www.oracle.com/technetwork/java/javasebusiness/downloads/java-archive-downloads-javase6-419409.html#jre-6u45-oth-JPR)
Also gegebenenfalls Java 1.7 deinstallieren und 1.6 (was 6 entspricht?!) installieren
– man sollte den JAVA_HOME Path setzen (http://stackoverflow.com/questions/2619584/how-to-set-java-home-on-windows-7)

Das seltsame ist, dass FD auf einmal diesen Fehler bringt. Bzw. zuerst hat es gar nicht mehr kompiliert, nachdem ich dann von Java 1.7 auf 1.6 gewechselt habe, ging der Debugger nicht mehr.

Viel Erfolg beim reparieren!

Written by am

December 17th, 2013 at 11:59 am

Posted in Flash/ActionScript

Tagged with

Richtige Flex SDK für Flashplayer Version verwenden

leave a comment

Irgendwie logisch, aber man kann es mal vergessen …
Hatte heute ein Problem mit der folgenden Fehlermeldung im FP 10.0.

VerifyError: Error #1053: Unzulässiges Außerkraftsetzen von z in mx.core.BitmapAsset.
VerifyError: Error #1053 Illegal override of z in mx.core.BitmapAsset.

Woran lags?
Ich hatte die Flex SDK 4.1 benutzt um für Flashplayer 10.0 zu kompilieren.
Natürlich muss man aber die ältere Flex SDK 4.0A verwenden, damit es mit FP 10.0 und nicht erst mit FP 10.1 läuft.

Written by am

December 1st, 2011 at 12:21 pm

Flashdevelop Installation

leave a comment

Flashdevelop ist eine sehr feine und außerdem auch noch kostenlose Entwicklungsumgebung für Flash (nicht mehr so hip) und aber auch Haxe (sehr interessant!)

Die Code Completion und Code Generation Features sparen viel Tipparbeit und der Outliner ermöglicht einen schnelle Überblick über Klassen. Das ist noch nicht alles … mehr Infos auf der offiziellen Website.

Für die Installation von Flashdevelop benötigt man:

Jetzt kann man unter Tools -> Install Software
installieren, was man braucht, Flex SDK, Git, Haxe etc.
Ich bin mir auch gar nicht sicher, ob man den Flash Player wirklich vorher schon installieren muss, hab es aber gemacht, weil ansonsten eine Warnung bei der FD Installation kommt.
So wie ich das sehe könnte man das jetzt auch noch über den AppMan (Install Software) installieren.development
Troubleshooting … sollte mit aktueller Installation nicht mehr nötig sein:
Unter Project -> Properties -> SDK muss der richtige Pfad zur SDK angelegt werden.
Wer wie ich unter Win7  x64 die Fehlermeldung “Unable to start java.exe” bekommt,
sollte die JAVA_HOME Umgebungsvariable ändern.
Viel Spass mit Flashdevelop!

Written by am

September 30th, 2011 at 7:07 am